Microsoft service degradation

Incident Report for ESADE

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 08:14 CEST

Investigating

We are monitoring an ongoing incident reported by Microsoft affecting some Microsoft cloud services.

According to Microsoft’s service health status page (https://status.cloud.microsoft/), some services may be experiencing degraded performance or partial unavailability. This incident is not caused by Esade systems or Esade infrastructure.

Some users may experience errors, slowness, or intermittent access issues when using Microsoft services.

We will continue to follow Microsoft’s updates and will update this notice when the provider publishes relevant information or confirms that the incident has been resolved.

We apologize for any inconvenience this may cause and appreciate your understanding.

If you have any questions or experience any issues, please contact us through our IT Support portal, by email or Teams at cau@esade.edu, or by phone at +34 93 567 6699 (extension 5555).
Posted Sep 01, 2026 - 10:06 CEST
This incident affected: Network & Authentication and Software & Apps.