Scientia integrations are temporarily unavailable

Incident Report for ESADE

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 15:13 CET

Identified

We will provide an update as soon as new information is available or once the integrations have been reactivated.

If you have any questions or experience additional problems, please don’t hesitate to contact us via our IT Support portal, e-mail or Teams (cau@esade.edu), or phone (+34 93 567 6699, ext. 5555).
Posted Nov 28, 2025 - 15:05 CET
This incident affected: Integrations.