Wi-Fi service disruption at Sant Cugat campus

Incident Report for ESADE

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 11:55 CEST

Investigating

We are currently experiencing an issue affecting the open Wi-Fi network “Esade” at the Sant Cugat campus.

The eduroam network is operating normally. While the issue is being resolved, we recommend connecting to eduroam instead.

Our technical teams are working to restore the service as soon as possible. We apologize for any inconvenience and will provide further updates when available.

If you have any questions or experience any issues, please contact us through our IT Support portal, by email at cau@esade.edu, or by phone at +34 93 567 6699 (extension 5555).
Posted Sep 07, 2026 - 11:08 CEST
This incident affected: Network & Authentication.