Scientia Integrations

Incident Report for ESADE

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 16:21 CEST

Identified

The Scientia integrations have been temporarily paused by our IT team due to unexpected data inconsistencies.

We are currently reviewing and correcting the data to ensure accuracy before reactivating the integrations.

We will provide updates as soon as more information is available.

If you have any questions or experience additional problems, please don’t hesitate to contact us via our IT Support portal, e-mail (cau@esade.edu), or phone (+34 93 567 6699, ext. 5555).
Posted Jun 19, 2025 - 09:14 CEST
This incident affected: Integrations.