Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2025 - 18:00 CET
Scheduled
Thursday, November 27th, there will be a scheduled SAP Production R/3 maintenance from 18:00h to 19:00h.
SAP will not be accessible during this time. We apologize for any inconvenience this may cause and appreciate your understanding.
If you have any questions or encounter any issues, please do not hesitate to contact us. You can reach us through our IT Support portal, by email at cau@esade.edu, or by phone at +34 93 567 6699 (extension 5555).
Posted Nov 26, 2025 - 11:26 CET
This scheduled maintenance affected: Economics & Human Resources (People).