Purchasing portal failure
Incident Report for ESADE
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 08:25 CEST
Identified
The purchasing portal is degraded and may not be working properly. You may not be able to login or load the purchasing portal.

Sorry for the inconvenience.

If you have any questions or problems, please don’t hesitate to contact us via our portal IT Support, e-mail (cau@esade.edu) or phone (+34 93 567 6699, ext. 5555).
Posted Sep 12, 2024 - 08:19 CEST
This incident affected: Economics & Human Resources (People).