Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 12, 2026 - 11:18 CEST
Scheduled
We are performing scheduled maintenance on PeopleSoft today between 11:00 and 18:00 CET. During this period, users may experience intermittent performance degradation. We will monitor the service and provide updates if needed.
Posted Jun 12, 2026 - 11:17 CEST
This scheduled maintenance affected: Teaching & Learning Platforms.