Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2026 - 22:00 CEST
Scheduled
Due to a scheduled VMware server upgrade, all services in Building 3 and Madrid will be unavailable from 10:00 PM on September 16 until 1:00 AM on September 17.
We apologize for any inconvenience.
If you have any questions or experience any issues, please contact us through our IT Support portal, by email or Teams at cau@esade.edu, or by phone at +34 93 567 6699 (extension 5555).
Posted Sep 15, 2026 - 12:40 CEST
This scheduled maintenance affected: Network & Authentication.