Auto-save not working for OneDrive / SharePoint files opened via File Explorer

Incident Report for ESADE

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 08:08 CEST

Update

Microsoft are continuing to monitor the fix deployment which requires more time than previously expected to complete. An estimated timeline for the completed deployment of the fix and the remediation of impact is expected to be available by they next scheduled update today at 8:30PM
Posted Jun 12, 2025 - 07:52 CEST

Update

We are continuing to monitor for any further issues.
Posted Jun 11, 2025 - 08:48 CEST

Monitoring

Microsoft have initiated the deployment of the fix and they are monitoring it’s progress to ensure it completes to resolve this issue as expected.
Posted Jun 10, 2025 - 08:20 CEST

Identified

We are currently experiencing an issue where some users may find that auto-save does not work when opening files from OneDrive or SharePoint Online through File Explorer.

Files opened this way in Microsoft 365 apps (e.g., Word, Excel) may not auto-save as expected. This issue is not caused by our systems — it originates from a recent Microsoft update.

Until Microsoft releases a fix, we recommend using the Microsoft 365 web apps (e.g., Word for the web, Excel for the web) to ensure auto-save works properly.

If you have any questions or experience additional problems, please don’t hesitate to contact us via our IT Support portal, e-mail (cau@esade.edu), or phone (+34 93 567 6699, ext. 5555).
Posted Jun 05, 2025 - 10:02 CEST
This incident affected: Software & Apps.