Salesforce Global Service Disruption

Incident Report for ESADE

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 08:06 CEST

Monitoring

Salesforce has deployed the next phase of its fix across the remaining affected instances. However, some ESADE users may continue to experience severe delays, intermittent errors, or be unable to access certain Salesforce services.

Salesforce continues to work on restoring the affected instances where the automated fix has not fully resolved the issue.

This is an external service disruption affecting Salesforce’s infrastructure. We are monitoring the situation and will provide further updates as they become available.
Posted Sep 16, 2026 - 17:07 CEST

Investigating

Salesforce is currently experiencing a widespread service disruption affecting multiple instances across all regions, including SWE16 and SWE50.

Users may experience severe delays, intermittent errors, or be unable to access certain Salesforce services. This is an issue affecting Salesforce’s infrastructure and is not specific to our systems.

Salesforce is actively investigating the incident. Further updates will be provided as soon as more information becomes available.

If you have any questions or experience any issues, please contact us through our IT Support portal, by email or Teams at cau@esade.edu, or by phone at +34 93 567 6699 (extension 5555).
Posted Sep 16, 2026 - 11:09 CEST
This incident affected: Admissions, Sales, and Careers.